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WELCOME TO WYLDFYRE 

Welcome to the Report Writer training class.  We are pleased to have you 
join us today.  We think you will find this module to be exciting and useful.  
Report Writer is a WyldFyre Listings software that allows you to design real 
estate reports, flyers, posters, CMA’s, labels and books.  You can modify 
any of the existing reports and formats.  Report Writer is designed to be 
tightly integrated with your MLS data and photographs.   
 
 
 

CLASS OBJECTIVES 

This class covers how to create the following report styles: 
 

 Normal  
 Vertical 
 CMA  
 Vertical CMA 
 Labels 
 Books 

 
In addition, you will learn how to insert, format and delete the following: 

 
 Text fields 
 Data fields 
 Tag fields  
 Date, Time & Page Numbers  
 Headers/Footers & Status Headers/Status Footers 
 Date Difference Fields  
 Feature Blocks 
 Lines 
 Boxes 
 Common phrases 
 Merging Fields 
 Bar Codes 
 Record Index 
 Calculated Fields 
 Picture grids 
 Images 
 Agent Photo 
 Broker Logo 
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CHAPTER 1 – GETTING STARTED 

Report Writer is a program within Listings. You can open Report Writer 
through the Start Menu or open it after you have Listings open.   
 

Opening Report Writer through the Start Menu 

Click on Start > Programs > WyldFyre > WyldFyre 6 > Report Writer.  
The Report Writer program will open. 
 

Opening Report Writer While in WyldFyre Listings 

 
1. From WyldFyre Listings click Tools > Report 

Writer or click on the rpt writer icon on your Quick 
Access toolbar.  

 
2. The Tip of the Day window will open.  Click on 

the Close button to close the window.   
 
 

Main Window 

The Main window is your entrance into Report Writer and consists of a 
Title Bar, Menu Bar, Toolbar and Status Bar. 

 
Title Bar 
 

    Menu Bar 
     
    Toolbar 

 
 
 
 
 
 

 
 
 
 
 
 
Status Bar 
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Toolbar 

 
The Toolbar provides one-click buttons for the most commonly used 
features in Report Writer.  You can change the appearance of the toolbar or 
add additional toolbars by clicking View > Toolbars.  
 

  
 
  
 
     
 

 

Status Bar 

The status bar displays the current state of the open Report Writer project. 
It has four sections; the first part of the status bar will tell you the Property 
Class of the report, the second part will display your Report Type, the third 
part will display the field selected and the fourth part will display the 
selected field justification. 
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CHAPTER 2 – SETTING UP YOUR SOFTWARE 

Setting up Default Information 

You can change the following default settings for your reports. 
 
1. From the Main Window in Report Writer, click 

File > Setup Defaults.  The Setup Defaults 
window opens with the Margins tab displayed.  

 
2. While on the Margins tab, set the top, bottom, left 

and right margins. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
3. Click on the Font tab to display the options for changing the Font, Size, 

Effects and Color.  This becomes the setting for all of the fields in the 
report. 
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4. Click on the Options tab to display the miscellaneous options. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Show Images:  If you check this option, you will see the actual 
image in the creation of your report.  If the option is unchecked, 
you will see the path and name of the image in your report and the 
image will only be seen when viewing your report (see Inserting an 
Image on page 25).  If you don’t turn this on as a default, you can 
do it for each report by clicking on Page > Show Images when 
designing the report. 
 

 Auto Label:  If you check this option, then when placing a data 
field in your report, the tag (or text) label is automatically inserted 
before the data field.  If the option were unchecked, then you would 
need to insert the tag (or text) label for each report (see Inserting 
and Formatting Text Fields on page 12 or Inserting and Formatting 
Tag Fields on page 16).  If you don’t turn this on as a default, you 
can do it for each report by clicking on Page > Auto Label when 
designing the report. 
 

 Show Page Break:  If you check this option, then Report Writer 
can highlight the page in order to help you layout your report. 

 
5. Click Save when finished. 
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CHAPTER 3 – DESIGNING A NORMAL STYLE REPORT 
 
When designing a report, you are creating a template.  All of the photo and 
data fields will remain blank.  To view your report, you must go back into 
Listings and this is when the data from the Property Listing Table will 
populate the fields. 
 

Opening a New Report 

1. Click File > New or click on the New button on 
your toolbar.   

 
2. A list of all the property classes available will 

appear in the Select Class box.  Click the desired 
class of property for which you wish to design a 
report.  Note: the number of classes available is 
dependent upon your MLS. 

 
3. Select the Report Type of Normal.  
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4. Click OK to continue.  A blank report will open for you to design your 
report as seen on the next page. 

 
 
 
 
 
 
 
Rulers 
 
 
 
 
 
 

   
    Access Bar 

 
                Data Fields 
 

Setting up a New Page 

 
1. Click Page > Page Setup.  The Page Setup 

window opens.   
 

2. Adjust Margins, Orientation, Paper Size, 
Number of Pages, and Header/Footer Heights 
as desired. 
 

3. Click OK when finished. 
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Setting up the Grid 

The grid is used as a visual aid for placing and aligning fields.  Report 
Writer opens with a grid displayed in 1 square inch increments.  You can 
control the grid display, and sizing and whether you would like objects to 
snap to the grid with the Grid toolbar.  The grid will not be shown or print 
on the reports when viewed in the Property Detail section.   
 
1. Click Page > Grid > On/Off.  This will turn 

off the grid function and the check mark will 
disappear.  Go back to Page > Grid > On/Off 
and the function will be turned back on and the 
check mark will appear again. 

 
2. If Snap Grid is checked, you will have an 

easier time aligning fields when they are placed 
on the page.  When you place or move an 
object, its upper left corner will automatically 
snap to the closest grid intersection point.  To 
turn off the snap function, click Page > Grid > 
Snap and the check mark will disappear. 
 

Setting up the Toolbars 

Once you are in the new report window, you  
have additional toolbars that can be added to 
your main toolbar for easy access to the most 
commonly-used commands.   
 
You can add additional toolbars by clicking View > 
Toolbars and selecting the toolbar to be added.  In our 
example, we added the Style toolbar. To remove the 
added toolbar, simply go back and uncheck the option. 
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Access Bar 

The Access Bar at the bottom of the open report window allows quick and 
easy access to the Report Body, Page Headers and Footers and the 
Background Layer. 
 
     Page             Background 
                      Header                    Layer 
 

 
 

   
Body         Page 

       Report                  Footer 
 
 

 Tip:  The Background Layer is designed for watermarks and other 
background images.  If you have a large bitmap in the background 
that you use as a watermark, and multiple small fields in front of it, 
building a report can be cumbersome because every time you click on 
the small fields, you may accidentally click on the watermark.    The 
Background Layer prevents this from happening. 

 
 

Formatting Page Headers  

You may choose to divide your page into sections called headers and 
footers.  The ability to define Page Headers and Footers has been provided 
as a way to include information in your report that is specific to a particular 
client or is useful in identifying the document to others.  You can insert the 
date, time and page number by selecting the appropriate field from the 
Insert menu (see Inserting and Formatting Date and Time on page 44 and 
Inserting and Formatting Page Numbers on page 45). 
 
Note:  In the Property Detail Report, the headers and footers are not 
viewable.  They will display only when you print your report. 
 
 
1. To access and view the page header, click Page > View 

Page Header or click the H on the Access Bar at the 
bottom of your screen. 
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2. The screen will split horizontally near the top and should look like the 

picture below. 
 
 
 
 

 
 
 
 
 

 Tip:  You can resize the Page Header by placing the cursor on the dotted 
line.  It will turn into a resize cursor.  Move it up or down to make the 
header smaller or larger.  Or you can go to Page > Page Setup and 
change your Header settings there. 
 

 

Formatting Page Footers 

1. To access and view the page footer, click Page > View 
Page Footer or click the F on the Access Bar at the 
bottom of your screen. 
 
 
 
 

 
 

2. The screen will split horizontally near the bottom and should look like 
the picture below. 

 
 
 
 
 
 
 
 
 
Note:  If the BkGrnd button is selected, then you can’t access the headers or 
footers. 
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Show Screen Lines/Page Breaks 

In order to help you layout your report, Report Writer 
can highlight the screen borders and page breaks.  You 
need to beware of those parameters in order to make 
your report look professional.  You can turn these 
functions on/off for each report by clicking Page > 
Show Screen Lines or Page > Show Page Breaks. 
 
Note: A check mark next to the function means it is  
turned on. 
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CHAPTER 4 – INSERTING & FORMATING TEXT, DATA 
AND TAG FIELDS 
 

Inserting and Formatting Text Fields 

Text fields are key components of any report.  You can place text fields on 
your report in the Header or Footer areas, as a way to describe data fields 
or to add your own comments.  

 
To insert a text field follow these steps: 
 
1. Click Insert > Text.  The Text Setup window opens. 

 
2. Type the text you desire in the Enter Desired Text field. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Click on the Font tab to select your Font, Font Style, Size and Color.   
 

4. Click OK after making your selections.  
 

5. The Text Setup window will close and take you back the Main window 
of Report Writer.  Your cursor will change shapes from a Pointer to an 
Insert cursor.  To drop the text on the page simply position it and click 
once. 
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6. To format a text field, double click on the field and the Text Setup 

window will open.  Click on the Font tab to make your selections.  
Click OK when done. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
7. To move your field, simply click and drag the field to the desired 

location. 
 

8. To delete you text field, simply click on the field and click Edit > 
Delete. 

 
 

 Tip:  You can center text fields on your page.  Click Align > Center 
on Page to center the field if you are printing your report.  Click 
Align > Center on View to center the field on the screen for viewing 
purposes only. 
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 Tip:  You can get a description 
of the characteristics of the text 
field, such as Font, Size, etc. by 
holding your mouse over the 
field for at least 1 second and 
the information pops up on 
your screen. 

 
 

Inserting and Formatting Data Fields 

Data fields are the most important elements in the creation of a report.  
Data fields are directly linked to the information contained in your MLS 
and the Property Listing Table.  When you insert a data field into your 
report, that field will be updated dynamically when you scroll through 
properties in the Property Listing Table. 

 
 
 
 

 
 
 
Scroll bar 

 
 
 
 
 
 
 
 

 
Data Field Selection box 
 
 

1. Data fields are listed in the Data Field Selection box.  This box 
automatically opens when you create a new page.  If the box is not 
visible on your page, then click View > Toolbars > Fields or right 
click your mouse and click Fields. 
 

2. Scroll down the list of data fields displayed in the Data Field Selection 
box and select a field by dragging and dropping it into the desired area 
in the report. 
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3. Your cursor will automatically change shape from a Pointer to an Insert 
cursor.  Move the cursor to the point where you want to place the data 
field and click once. Note:  If you have the Auto Label function 
turned on, then a text label will be placed in front of your data field 
(see Setting up Default Information on page 4).  If it is turned off, 
then you need to insert your own text fields (see Inserting and 
Formatting Text Fields on page 12 or Inserting and Formatting 
Tag Fields on page 16). 
 
 

 
 

 
 

Data Fields 
 

 
Text Fields 
 
 
 
 
 
 

4. Repeat the above steps until you have placed all of the desired data 
fields into your report.  All of your data fields will have a box around 
the field where all of your text fields will not have a box around the 
field. 

 
5. To move your field, simply click and drag the field to the desired 

location.  
 

6. To format your field, double click on it and the Field Setup window 
will open.   
 

7. On the Field tab, check the box next to 
Use long descriptive names if you want 
the data field to be spelled out versus 
abbreviated and/or change the font by 
clicking on the Font tab. 
 

8. Make your changes and click OK. 
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9. Once you have placed all of the fields on the report, you can hide the 
Data Fields listbox by clicking View > Toolbars > Fields or right click 
your mouse and uncheck Fields. 
 

 
 Tip:  You can get a description of the characteristics of 

a data field, such as Font, Size, etc. by holding your 
mouse over the field for at least 1 second and the 
information pops up on your screen.  

 
 

Inserting and Formatting Tag Fields 

If you have the Auto Label function turned off when placing data fields in 
your report, then you can insert a tag field to label each data field. 
 
To insert a tag field follow these steps: 
 
1. Click Insert > Tag.  The Tag Field Setup window 

opens. 
 

2. In the Select a Field section, click on the drop down 
arrow and select the field you need for your report.  

 
3. In the Display Option section, select how you would 

like the field to display in your report. If you select 
Other, then type the field name as you want it to appear 
in your report. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Click on the Font tab to select your Font, Font Style, Size and Color.   
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5. Click OK after making your selections.  
 

6. The Tag Field Setup window will close and take you back the Main 
window of Report Writer.  Your cursor will change shapes from a 
Pointer to an Insert cursor.  To drop the text on the page simply 
position it and click once. 
 

7. To format a text field, double click on the field and the Tag Field Setup 
window will open.  Click on the Font tab to make your selections.  
Click OK when done. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

8. To move your field, simply click and drag the field to the desired 
location. 
 

9. To delete you text field, simply click on the field and click Edit > 
Delete. 
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Inserting and Formatting Multiple Feature Data Fields  

 
Some data fields contain multiple fields, which are called Array Fields.  
These are inserted in the same manner as any other data field by dragging 
and dropping it into the desired area in the report.  The example below 
shows the field Master Bedroom Description. 
 
 
 
 
 
 
To format a multiple feature data field, double click on it to open the 
Multiple Feature Field Setup window. Change the settings in the Array 
Field tab (see below) and/or make changes in the Font tab in the same 
manner as any other data field. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Number of Columns to Display:  Use this feature to set the number of 
columns to display in your report. 

 
 Number of Visible Fields:  If you choose a field that has many display 

fields, you can elect to show only some of the fields in order to save 
space. 

 
 Start Field: This designates which field of the multiple feature fields will 

display first. 
 

 Use long descriptive names:  Select this option if you want to see the full 
name of a field versus an abbreviation. 
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Aligning Text and Data Fields 

You can select objects to align them on the page. You can select objects of 
the same type, or any combination of objects. 

 
1. Highlight the fields to align.  In the example below, we want to align 

the data fields City, List Price, Bedrooms and Bathrooms to the left.   
 
2. To select multiple fields, press and hold the Ctrl key on your keyboard 

and then select the items or click Edit > Select All. 
 
 
 
 
 
 
 
 
 

3. Click Align > Left. If you want the fields to be spaced evenly, then 
click Align > Space Evenly > Down.  If your fields are going across 
the page, then use Align > Space Evenly > Across. 
 
 
 
 
 
 
 
 
 

4. Continue with additional fields. 
 
 

 Tip:  You can center data fields on your page.  Click Align > Center 
on Page to center the field if you are printing your report.  Click 
Align > Center on View to center the field on the screen for viewing 
purposes only. 

 

 
 
 
 
 
 



               Chapter 4 – Inserting & Formatting Text, Data and Tag Fields 

  Page 23 

Justifying Data Fields 

When you place a data field on your report it defaults to left justify.  You 
have the option to change it to center or right justify.     
 
 

 
1. Click on the data field to justify so that the field is 

highlighted.  
 

2. Click Field > Center Justify to center the data within the 
box (see below) or Field > Right Justify.  In our example, 
we selected Center Justify. 

 
 
 

3. You can undo your justification by clicking on Edit >   
Undo Justification. 
 
 

Deleting Items 

You may need to delete text or data fields from your report.  Basically 
anything that you inserted can be deleted the following way: 
 
1. Highlight the item to delete. 

 
2. Click Edit > Delete or press your Delete key on your 

keyboard. 
 

3. You have one chance to bring back the deleted item 
by clicking Edit > Undo Cut/Delete. 
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Resizing Data Fields 

In some cases you my need to resize your data fields to fit on the page.  To 
re-size a field, click once on the field to select it.  Place your cursor on one 
of the blocks; the cursor will change from a Pointer to a Resize cursor.  
Drag the mouse in the desired direction until it has reached the desired size. 
 

Moving Fields 

To move items around your screen, click on the item so that it is 
highlighted.  Once highlighted, then click in the middle of the item and 
drag the field to the appropriate place. 
 
To select multiple fields, press and hold the Ctrl key on your keyboard and 
then select the items or click Edit > Select All. 
 

Associating Field Objects with Property Status 

Associating fields with certain statuses can be very beneficial.  It ensures 
that only the fields that are relevant to that status will be viewable.  For 
example, you may want to see the Sold Price Data field on your report, but 
only for the properties with a Sold status. 
 
To associate a field with a status follow the steps below: 
 
1. Click on the field to highlight it. 

 
2. Click Field > Associate.  The Associate Field 

window opens. 
 

3. Click on the status that you want to associate.  
 
 
 
 
 
 
 
 
 
 
 
 
 

4. To associate multiple statuses with a field, press and hold down your 
CTRL key on your keyboard and select multiple fields. 
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5. Click OK. 
 
6. If you added a text field in front of your data field, then you need to 

associate the text field as well by following steps 1-5 above.  
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CHAPTER 5 – INSERTING IMAGES 
 

Inserting Picture Grids 

One of the key features of Report Writer is the ability to display and print 
pictures of properties.  The mechanism for displaying pictures is the picture 
grid.  The Picture Grid has fourteen pre-formatted picture layouts available 
with choices ranging from one picture to nine pictures.  Follow these steps 
to insert a picture grid: 
 
1. Click Insert > Picture Grid. 

 
2. Move the Insert Cursor to the desired location on the 

page and click once to drop it.  The software will 
default to the one picture grid as shown below.  
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3. To change the formatting of the picture grid, 
double click on the picture grid.  The Picture 
Style Selection window opens.   

 
4. Select a specific picture format style between 1 

and 9 photos.  Select the Style from the list and 
click OK.   

 
5. The example below shows the 3-picture style.  

 
6. To re-size the picture grid, click once on the picture grid to select it.  

Place your cursor on one of the blocks; the cursor will change from a 
Pointer to a Resize cursor. Drag the mouse in the desired direction until 
it has reached the desired size. 
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Inserting an Image 

Images add pizzazz to any report or flyer.  Report Writer supports the 
inclusion of many different types of images in your reports.  Images may 
include your company logo, your own photograph, or real estate-related 
clip art.  There are many sources of image files, including those that you 
scan into your system.  Follow the steps below to add an image to your 
report: 
 
1. Click Insert > Image.  The Image dialog box will open 

as shown below.   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
2. Locate your saved image and double click on the File Name or 

highlight your file and click the Open button.   
 
3. Your cursor will change shapes from a pointer to an Insert Cursor.  

Move the Insert cursor to the point you wish to place it on the page.  
Click once to place it.   

 
4. You will see either a gray image that states Image and displays the path 

and name of the image, or the actual image.  Click Page > Show 
Images to see if the image is available. 

 
5. To re-size the image, click once on the image to select it.  Place your 

cursor on one of the blocks; the cursor will change from a Pointer to a 
Resize cursor.  Drag the mouse in the desired direction until it has 
reached the desired size. 
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Inserting an Agent Photo 

You have the option to insert an Agent Photo into your report.  For the 
photo to appear in your report, you must first add the information in 
Listings using Options > Preferences. Go to the Primary Agent tab, and in 
the Agent Photo Location box, click on the Browse button to find the 
location of your Agent Photo. Then follow the steps below to add your 
Agent Photo to your report: 
 
1. Click Insert > Agent Photo.   
 
2. Your cursor will change shapes from a pointer to an 

Insert Cursor.  Move the Insert cursor to the point you 
wish to place it on the page.  Click once to place it.   

 
3. To re-size the image, click once on the image to select it.  

Place your cursor on one of the blocks; the cursor will 
change from a Pointer to a Resize cursor.  Drag the 
mouse in the desired direction until it has reached the 
desired size. 

 
 

Inserting a Broker Logo 

You have the option to insert a Broker Logo into your report.  For the 
photo to appear in your report, you must first add the information in 
Listings using Options > Preferences. Go to the Brokerage tab, and in 
the Brokerage Logo Location box, click on the Browse button to find the 
location of your Logo. Then follow the steps below to add the Broker Logo 
to your report: 
 
1. Click Insert > Broker Logo.   
 
2. Your cursor will change shapes from a pointer to an 

Insert Cursor.  Move the Insert cursor to the point you 
wish to place it on the page.  Click once to place it.   

 
3. To re-size the image, click once on the image to select 

it.  Place your cursor on one of the blocks; the cursor 
will change from a Pointer to a Resize cursor.  Drag 
the mouse in the desired direction until it has reached 
the desired size. 
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CHAPTER 6 – INSERTING ADDITIONAL FEATURES 
 

Inserting and Formatting Lines 

You can insert horizontal or vertical lines in your report to highlight or 
underline objects.  To insert a line follow these steps: 
 
1. Click Insert > Line.  Your cursor will change shapes 

from a Pointer to the Line Draw Cursor.   
 

2. Move the Line Draw Cursor to the point where you wish 
to begin the line. 
 

3. Click and drag the left mouse to anchor one end of the 
line; and drag the mouse in a straight vertical or horizontal 
direction to the point where you want the line to end.  
 

4. To re-size the line, click once on the line to select it.  
Place your cursor on one of the blocks; the cursor will 
change from a Pointer to a Resize cursor.  Drag the mouse in the 
desired direction until it has reached the desired size. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. To format a line, double click on the line 
and the Line Setup window will open.  
You can change the line width.  The style 
can also be changed from a solid to a 
dashed line if the width is set to 1.  After 
settings have been changed click on OK 
to activate these changes.  
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Inserting and Formatting Boxes 

You can insert boxes in your report to highlight or outline objects.  To 
insert a box follow these steps: 
 
1. Click Insert > Box.  Your cursor will change shapes from 

a Pointer to the Box Draw cursor.  
 
2. Move the Box Draw Cursor to the point where you wish to 

begin the box. 
 

3. Click and drag the left mouse to anchor one end of the 
box; and drag the mouse to the point where you want the 
box to end.  
 

4. To re-size the box, click once on the box to select it.  Place your cursor 
on one of the blocks; the cursor will change from a Pointer to a Resize 
cursor.  Drag the mouse in the desired direction until it has reached the 
desired size. 

 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
5. To format a box, double click on the box and the Box Setup window 

will open. Make your changes and click on OK. 
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 Shadow: If you want a shadow around your box, then click the 
Enable Shadow box.  You can also change the width and color of 
the shadow. 
 

 Border:  You can change the shape of the box to Round Corners as 
well as the width and color of the border. 
 

 Interior:  You can control the Pattern and Color of your box’s 
interior.  
 

6. When drawing a box around text or picture grids, etc., you will notice 
that the information disappears.  To make the text or picture reappear, 
click Field > Send to the Back.  This will send the box to the back and 
allow you to see both the text or picture grid and the box. 
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Inserting Common Phrases 

Report Writer is pre-programmed with common phrases describing real estate 
property.  You can edit any of the phrases on the list or you can add your own 
phrases.  To insert common phrases follow these steps: 
 
1. Click Insert > Common Phrases.  The Common 

Phrases Setup window will open.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Select a phrase by clicking on it with the mouse.  To select more than 
one phrase, press and hold down the CTRL key on your keyboard and 
click on additional selections. 

 
 To add a new phrase, click on the New button and type the new 

phrase and click OK. 
 

 To edit a phrase, highlight the phrase and click on the Edit 
button.  Make your changes and click OK. 

 
 To delete a phrase, highlight the phrase and click the Delete 

button. Click OK to get back to the Setup window. 
 
3. Click on the Font tab to make any changes to the Font, Size and 

Effects. 
   
4. After selecting all of the desired phrases, click OK. 
 
5. Move the cursor to the desired position on the page and click once to 

place the phrases.   
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6. While highlighted you can move the phrases as a group.  Once phrases 
have been unhighlighted, you can select each of them individually and 
edit and format each one as a text field. 

 
 

 

 
 
 
 
 
 
 
 
 
 

 
 
 

Inserting and Formatting a Feature Block  

A Feature Block is a box containing all of the listings features. In order to 
fit all features in a feature block, you can resize the block, change the font 
attributes, and elect to abbreviate feature names or spell out the long, 
descriptive name. 
 
1. Click Insert > Feature Block.  Your cursor will change 

shapes from a Pointer to the Box Draw Cursor.   
 
2. Move the Box Draw Cursor to the point where you wish to 

begin the box. 
 

3. Click and drag the left mouse to anchor one end of the 
box; and drag the mouse to the point where you want the 
box to end.  
 

4. To re-size the box, click once on the box to select it.  Place 
your cursor on one of the blocks; the cursor will change 
from a Pointer to a Resize cursor.  Drag the mouse in the desired 
direction until it has reached the desired size. 
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5. To form at a feature block object, double click on the object to open the 

Feature Block Setup Box at the Attributes tab.   
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6. The Attributes tab includes the following formatting options: 
 

 Shrink text to fit box - In order to fit all features in the block, 
this option will reduce the font size based on the "Enter 
Minimum Font Size" option.  

 
 Minimum font size:  This option will reduce the feature font size 

down to the size you enter. If the font size is reduced to the 
minimum and not all features will fit in the block, the word 
"More" will appear at the end of the block when you view the 
report. 
 

 Use long descriptive names - Features are abbreviated, but 
you can spell them out by selecting this option. 

 
 Select Feature(s):  A list of all possible fields that can 

populate the feature block.  All of them will be highlighted 
when you open the Feature Block Setup window.  Deselect 
the features that you do not want to include in your report. 
 

7. The Label Font and Text Font tabs include the following formatting 
options: 
 
 
 
 
 
 
 
 
 
 

 Label Font: This is for formatting the label cell.  Adjust the 
Font, Size, Effects and Color.  An example of a label cell would 
be "Utility". 
 

 Text Font:  This is for adjusting the characteristics of the cell 
body.  An example of a cell body would be “Electric” and 
“Natural Gas”.  See Example on the next page. 
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Inserting and Formatting Text Blocks 

Text Blocks give you more flexibility when inserting text 
into your report.  Basically the function will allow you to 
wrap your text. 
 
1. Click Insert > Text Block.  Your cursor will change 

shapes from a Pointer to the Box Draw Cursor.   
 
1. Move the Box Draw Cursor to the point where you wish 

to begin the text box. 
 

2. Click and drag the left mouse to anchor one end of the 
text box; and drag the mouse to the point where you 
want the text box to end.  
 

3. To re-size the text box, click once on the box to select it.  Place your 
cursor on one of the blocks; the cursor will change from a Pointer to a 
Resize cursor.  Drag the mouse in the desired direction until it has 
reached the desired size. 
 

4. Type the desired text in the box.  Format the text by highlighting the 
information and selecting options from the Field menu or the Style 
toolbar if added to your screen. 
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5. To delete the entire Text Block, select the Text Block with your mouse 
and then click Edit > Delete. 
 

6. To delete the entire text from within a Text Block, highlight the text 
that you want to delete with your mouse.  Press the Delete key on your 
keyboard. 
 

7. If you want to delete individual characters, then place the cursor to the 
right of the character to delete in the text block and press the 
Backspace key on your keyboard. 
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Inserting and Formatting Merging Fields 

With this feature you can combine text and data fields or just data fields.  A 
common example would be to merge the City, State and Zip Code fields 
together or Street Number and Street Name.  If you don’t merge the fields, 
then you will have a large gap between the two fields to account for the 
largest amount of characters.   
 
1. Click Insert > Merge Field.  The Merge Field Setup 

window will open. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
2. Click on the field in the Available Data Field(s) column. 
 
3. Click Insert or double click on the field to move it over to the Format 

String list. 
 
4. While in the Format String list, you can add spaces or any desired text 

or numbers. 
 
5. In the example below, we inserted City, then typed a comma, added a 

space, typed TX, added 2 spaces and then inserted Zip Code. 
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6. Click on the Font tab to change the Font, Size, Effects and Color. 
 
7. Click OK when finished and your cursor will change shapes from a 

Pointer to Insert Cursor.   
 
8. Move the Insert Cursor to the point where you wish to place the field. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
9. To re-size the box, click once on the box to select it.  Place your cursor 

on one of the blocks; the cursor will change from a Pointer to a Resize 
cursor.  Drag the mouse in the desired direction until it has reached the 
desired size. 

 
 
 
Fields Not Merged 
 
 

Fields Merged 
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Inserting and Formatting a Bar Code Field 

You can insert a bar code field which will populate with information such 
as Zip Codes or information that has been scanned into your computer. 
 
1. Click Insert > Bar Code Field.  The Field Setup 

window opens. 
 
2. From the Select New Field listbox, choose the field 

you want to insert in the bar code.  Typically this will 
be the Zip Code field.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
3. Click on the Font tab to format Font, Size, Effects and Color. 
 
4. Click OK when finished and your cursor will change shapes from a 

Pointer to Insert Cursor.   
 
5. Move the Insert Cursor to the point where you wish to place the field. 
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CHAPTER 7 - INSERTING CALCUALTED FIELDS 

Inserting and Formatting Date Difference Fields 

The program gives you the ability to show the difference (subtraction) 
between two date fields in the database.   
 
1. Click Insert > Date Difference.  The Date Difference 

window will open.  
 

2. There are two list boxes: Ending Date and Beginning 
Date. Each contains all of the fields in an MLS record 
which can be used in a mathematical subtraction.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
3. To set up a difference field, highlight a field from the left list box and 

highlight the field in the right list box that will be subtracted from the 
Ending Date.  Click on OK. 
 

4. Your cursor will change shapes from a Pointer to an Insert cursor.  
Move the cursor to the point where you want to place the difference 
field and click once. 
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5. Once the field has been placed, you can format it by double clicking on 
it to bring up the Field Setup window.  Make your changes and click 
OK. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Tip:  To see the formula you used, click on the field and check your 
status bar or hold your mouse over the field for at least 1 second and 
the information pops up. 
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Associating Fields 

There may be fields you would like to associate with certain statuses.  For 
example, if you include the date difference fields on your report, you will 
want to associate the various dates with specific statuses. 
 
For example, when you place a date difference field of Sale Date to List 
Date, you may want to associate this field with pending and sold statuses 
only.  When you place a difference field of List Date to Today you may 
want to associate this field with Active statuses only (see Associating Field 
Objects with Property Status on page 21). 

 
 

Inserting a Record Index 

The Property Listings table contains a record number to keep track of each 
property.  By inserting the record number in your report, it gives you an 
easier way to manage the property reports.   
 
1. Click Insert > Record Index.  The Record Index 

Setup window opens. 
 
2. In the Select Format listbox, select a display format for 

the property row number. 
 
 

 

 

 

 

 
 
 
3. Click the Font tab to change the Font, Size and Effects. 
 
4. Click OK when finished and your cursor will change shapes from a 

Pointer to Insert Cursor.   
 
5. Move the Insert Cursor to the point where you wish to place the field. 
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Inserting a Calculated Field 

The Calculated Field allows you to include your own custom-made 
calculation formulas developed from the available data fields. 
 
1. Click Insert > Calculated Field.  The Calculated Filed 

Setup window opens. 
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2. Select a field in the Select Field listbox and click the Insert button or 
double-click on the field. 

 
3. Add operators (addition, subtraction, etc.). 
 
4. Continue in this manner until you have all desired fields and operators.  

In our example below, we selected Original List Price minus the Sales 
Price.  We also added a dollar sign and comma. 

 
5. Type in a name for your calculation in the Calculation Name field. 
 
6. In the Format section, specify the number of characters after the 

decimal point that the calculation formula will calculate.  If you want to 
include a Dollar Sign and/or commas, then check those boxes. 

 
 
 
 

 

 
 
 
 
 
 
 
 
 
 
 
7. Click the Font tab to change the Font, Size, Effects and Color. 
 
8. Click OK when finished and your cursor will change shapes from a 

Pointer to Insert Cursor.   
 
9. Move the Insert Cursor to the point where you wish to place the field. 
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Inserting and Formatting Date and Time 

You may want to include today's date or time on any of the reports that you 
create.  Once placed, the software automatically prints the current date in 
the Date field and/or the Time in the Time Field.   
 
1. To add the date and/or time, click Insert > Date or 

Insert > Time.  Your cursor will change from a 
Pointer to an Insert cursor.  Move the cursor to the 
point where you want to place the fields and click 
once.  You can place these fields in the header or 
footer area as well.  In our example, we placed the 
Date and Time field in the page footer. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Once the field has been placed, you can format it just like any other 
field by double clicking on it to bring up the Date or Time Setup 
window.  Click on the Font tab to make your changes. 
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3. To move your field, simply click and drag the field to the desired 
location. 

 
4. Make your changes and click OK. 

 
 

Inserting and Formatting Page Numbers 

Page numbers can only be inserted in the header or footer section.  
 
1. Click Page > View Page Header or Page > View Page 

Footer depending on where you want to place the page 
number.  In our example, we placed the page number in 
the page header. 
 

2. Click on Insert > Page Number.  
 

3. Your cursor will change shapes from a Pointer to an Insert 
cursor.  Move the cursor to the point where you want to 
place the page number and click once.  Don’t forget, you 
can add text in front of any data field, so that the field is 
labeled as “Page”.  
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4. Once the field has been placed, you can format it by double clicking on 
it to bring up the Font window.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
5. To move your field, simply click and drag the field to the desired 

location 
 
6. Make your changes and click OK. 
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CHAPTER 8 – SAVING, VIEWING, OPENING, REVISING, 
PRINTING & DELETING REPORTS 
 

Saving a Report 

1. To save a report, click File > Save As or click the 
Save button on your toolbar.  The Save As dialog 
box will open.   
 

2. The program defaults to the Cust_rpt directory, 
which is where all of your custom reports are 
saved. 
 

3. The Save as type field has a default name of *.rp1 
for class 1 reports, *.rp2 for class 2 reports, etc. 
and should not be changed.   
 

4. Type your report name in the File name field. 
 

5. Click the Save button. 
 

6. Your saved file name now appears in the Title Bar. 
 
 

 

 

 
 
 

 Tip:  When you save the report after making some changes, click File 
> Save.  This will automatically save your report under the same 
name. 
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Viewing a Report 

Once you save your report, you can view it from the Property Detail 
Reports in Listings.  You must perform a search or open a saved search 
first before viewing the report.  
 
1. Perform a search or open a saved search. 

 
2. While at the Property Listing Table, click the 

Other Reports button on your tool bar or click 
Reports > Other Reports. The Reports - 
Residential window will open.   
 

3. To view your report, double click on the file name assigned to that 
report or click on the report name and click OK.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Tip:  Reports with an asterisk are those standard reports that are 
included with the program.  Note: The amount and types of reports is 
dependent upon your MLS. 

 
 Custom reports are the ones you created.  They are listed after the 

standard reports.  
 

 The two custom reports shown above were created in Class 1 so they 
must be viewed in a Class 1 search.  If you created a Class 2 report, 
then you would view that report in a Class 2 search. 
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Opening and Revising a Report 

Revisions to reports must be made in Report Writer, NOT in Listings.   
 
1. Open Report Writer. 

 
2. Open your saved report by clicking the Open button 

on your toolbar or clicking File > Open 
Custom Report.  
 

3. Double-click on the file to open or highlight the file 
and click Open. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. After you make your changes, you must save the report again by 
clicking File > Save.   

 
 

 Tip:  If you made changes to your report with Listings open, then 
when you go back into Listings to view your report, you will notice 
the message below pops up on your screen.  Click Yes to reload the 
changes to your report. 
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Printing a Report 

There are three different ways to print the Reports: 
 

 Click the print icon on your tool bar.  
 

 Click on File > Print Report. 
 

 Press the F5 key on your keyboard. 
 

 
1. It displays the default printer.  You 

can click on the pull down box to 
select other printers you have 
available.  
 

2. To print the current listing (the one 
that is highlighted in the Property 
Listing Table, click the Current 
Listing option. 
 

3. To print only the listings that you 
have previously marked, click the All 
Marked Listings option.  There will 
be a number just next to that option 
showing the number of properties to 
be printed.  In this example there are 
3.  You will multiple listings per page 
with this option. 
 

4. To print all of the listings, click the All Listings option 
 

5. To print one listing per page, click the One Listing Per Page option.  
 

6. You can choose the number of copies to be printed. 
 

7. The Print Orientation allows you to choose between Portrait or 
Landscape when printing a report.   

 
8. To preview the reports, click on the Preview button.  

 
9. Click on the OK button when you are ready to print your report. 
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Deleting a Report 

 
1. At the Main Window in Report Writer, click File > 

Delete Custom Report.  The Delete Custom Report 
window opens.  
 

2. Double-click on the file to delete or highlight the file 
and click Open. 
 

3. You will be prompted to delete the file.  Click Yes. 
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CHAPTER 9 - DESIGNING A VERTICAL STYLE 
REPORT 
 
A Vertical report allows you to create an appraisal-style report with photos 
and custom headers and footers.  You can even include a fixed-left side 
column for field labels. To create a vertical report, follow the steps below: 
 
1. Open Report Writer. 
 
2. Click File > New or click on the New button on 

your toolbar.   
 

3. A list of all the property classes available will appear 
in the Select Class box.  Click the desired class of 
property for which you wish to design the Vertical 
Report. 

 
4. Select the Report Type of Normal and Vertical.  
 
 
 
 
 
 
 
 
 
 
 
 
 
5. Click OK to continue.  A blank report will open for you to create your 

vertical report. 
 
 
 
 
 
Fixed 
Body 
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Inserting Text Fields in the Fixed Body  

The Fixed Body area allows you to insert text fields (see 
Inserting and Formatting Text Fields on page 12).   This 
becomes your fixed column for the field labels. 
 
 

Text fields inserted into  
the fixed body area 

 

Inserting Fields 

Since the vertical report is an appraisal style, it allows you to print three 
properties across the page. You can include a photo (see Inserting Picture 
Grids on page 23), but you need to be sure the size of the picture grid is 
small enough so that three can fit across the page when your print.  You 
can then add your Data Fields down the page (see Inserting and Formatting 
Data Fields on page 14) and you can include headers and footers.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Saving, Viewing, Opening, Revising, Printing and Deleting a 
Vertical Style Report 
 
To save, view, open, revise, print and delete a Vertical Style Report, you 
would follow the same steps you would take in a normal report (see 
Chapter 8 – Saving, Viewing, Opening, Revising, Printing and Deleting 
Reports on page 47). 
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CHAPTER 10 – DESIGNING A CMA AND VERTICAL 
CMA STYLE REPORT 
 
A CMA style report allows you to group your data and create summary 
fields for each status.  To create a CMA Style report, follow the steps 
below: 
 
1. Open Report Writer. 
 
2. Click File > New or click on the New button on 

your toolbar.   
 

3. A list of all the property classes available will appear 
in the Select Class box.  Click the desired class of 
property for which you wish to design the CMA 
Report. 

 
4. Select the Report Type of CMA Style.  
 
 
 
 
 
 

 

 

 
 
5. Click OK to continue.  A blank report will open for you to create your 

CMA. 
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Setting up a New Page 

 
1. Click Page > Page Setup.  The Page Setup window 

opens.   
 

2. Adjust Margins, Orientation, Header/Footer Heights 
and Status Header/Footer Heights as desired.  What’s 
different about the CMA style vs. the Normal style is 
that you now have Status Headers. 
 

3. Click OK when finished. 

 

 
 

                 Page Headers/Footers 
 
 

Status Headers/Footers 

 

 
 
 
 
 
 

 Tip:   Page Headers/Footers are the same as in a normal report (see 
Formatting Page Headers on page 9 and Formatting Page Footers on 
page 10).  Status Headers corresponds to the status of a property and 
Status Footers is the Summary of each status.  Report Writer groups 
the properties together by status. 

 
 
Status Headers 
 
 
 
 

Body 
 
 

Status Footer 
 
 
 



              Chapter 10 – Designing a CMA and Vertical CMA Style Report 

   Page 59 

 Tip:  When viewing the type of report on the previous page, you see 
only one property listed.  However, when you print the report, you 
will have multiple properties listed based upon your selection criteria 
when printing as seen below. 

 
 
 
 
 
 
 
 
 
 
 
 
 

Viewing Status Headers 

The status header is for displaying the property status at the beginning of 
each section of your CMA style report. 
 
1. To access and view Status Headers, click Page > View 

Status Headers or click on the SH on the Access Bar 
at the bottom of your screen. 

 
 

 
 

 
 

2. The screen will split horizontally near the top and 
should look like the picture below. 

 
 
 
 

 
 
 
 
 

 Tip:  You can resize the Status Header by placing the cursor on the 
dotted borderline.  It will turn into a resize cursor.  Move it up or down to 
make the header smaller or larger.  Or you can go to Page > Page Setup 
and change your settings there. 
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Inserting and Formatting Title Fields into Status Headers 

 
The Title Field displays the current status for each section of the CMA 
report. 
 
1. Click Insert > Title Field (you must have the View Status 

Headers section turned on to insert the Title Field).  
 

2. Drag and drop the cursor to the desired location.  You 
must drop this field somewhere in the Status Header area. 

 
3. Double click on the Title Field to format the Font, Size 

Effects and Color. 
 

4. If you plan to use column headings, such as Address, 
Beds, etc., then insert the headings in the Status Header 
area as text fields and format them (see Inserting and 
Formatting Text Fields on page 12 or Inserting and 
Formatting Tag Fields on page 16). 
 

5. Then add the Data Fields in the Body Area (see Inserting and 
Formatting Data Fields on page 14). 

 
 
Title Field 
 
 
 
 
 
 
 

Viewing Status Footers 

Status Footers define the text that is normally found at the end of each 
section of a CMA report. 
 
1. To access and view the Status Footer, click Page > 

View Page Footer or click on the SF on the Access 
Bar at the bottom of your screen. 
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2. The screen will split horizontally near the bottom and should look like 
the picture below. 

 
3. You can insert Page Numbers, Time, Date, Lines, Boxes, etc. 

 
 
 
 
 
 
 
 
 

 Tip:  if the BkGrnd button is selected, then you can’t access the headers or 
footers. 

 
 

Inserting and Formatting Summary Fields 

 
Following each section you can insert Summary Fields such as Total 
Number of Listings, Minimum or Maximum Price or Average Price to 
summarize information.  The Summary Field must be in the Status Footer 
area. 
 
1. Click Insert > Summary Field.  Release the mouse 

and the Insert Summary Field window opens.   
 

2. Select a field from the Select Type of Operation 
listbox. 
 

3. Select a field from the Select Field/Calculation listbox. 
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4. Move the Insertion cursor to the Status Footer section and place the 
field. 
 

5. Double-click on the Summary Field to format Font, Size, Effects and 
Color. 
 

6. If you want to label the Summary Field, then insert the text field and 
place in front of the Summary Field. 

 
 
 
 
 
 
 

Vertical CMA Style Report 
 
A Vertical CMA report is just like the Vertical report as seen on page 52, 
except that it allows you to group your properties by status.  To create a 
Vertical CMA report, follow the steps below: 
 
1. Open Report Writer. 
 
2. Click File > New or click on the New button on 

your toolbar.   
 

3. A list of all the property classes available will appear 
in the Select Class box.  Click the desired class of 
property for which you wish to design the Vertical 
CMA Report. 

 
4. Select the Report Type of CMA Style and Vertical.  
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5. Click OK to continue.  A blank report will open for you to create your 
Vertical CMA report. 

 
 
 
 
 
Fixed 
Body 
 
 
 
 
 
 
 
 
 
6. Insert text fields, data fields, and picture grids by following the 

example in Chapter 9 – Designing a Vertical Report on page 52 and 53.  
 
7. In addition, since this is a CMA style report, you can group your 

properties by status by using the Status Headers (see Inserting and 
Formatting Title Fields into Status Headers on page 57). 
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Saving, Viewing, Opening, Revising, Printing and Deleting a 
CMA or Vertical CMA Style Report 
 
To save, view, open, revise, print and delete a CMA or Vertical CMA Style 
Report, you would follow the same steps you would take in a normal report 
(see Chapter 8 – Saving, Viewing, Opening, Revising, Printing and 
Deleting Reports on page 47). 
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CHAPTER 11 – DESIGNING LABELS 

Designing labels with Report Writer is quick and easy.  You can create a 
generic label template that can import specific information from a group of 
listings. 
 
1. Open Report Writer. 
 
2. Click File > New or click on the New button on your 

toolbar.   
 

3. A list of all the property classes available will appear 
in the Select Class box.  Click the desired class of 
property for which you wish to design the labels. 

 
4. Select the Report Type of Label.  
 
 
 
 
 

 

 

 
 
5. From the Label Type listbox, click on the drop down arrow and select 

the type of label sheets you will be printing on. 
 
6. Click OK to continue.  A blank report will open for you to create your 

labels. 
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Inserting Fields 

Drag and drop the desired data fields onto the working area of the label 
and/or insert text fields.   
 
In the example below, we inserted CURRENT RESIDENT as a text field 
(see Inserting and Formatting Text Fields on page 12), merged the Street 
Number and Street Name fields and merged the City, State and Zip code 
fields (see Inserting and Formatting Merging Fields on page 36). 
 
 
 
 
 

 

 

 

 

 

 

 

 
 
 

Saving, Viewing, Opening, Revising, Printing and Deleting a 
Label Style Report 
 
To save, view, open, revise, print and delete a Label Style Report, you 
would follow the same steps you would take in a normal report (see 
Chapter 8 – Saving, Viewing, Opening, Revising, Printing and Deleting 
Reports on page 47). 
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CHAPTER 12 – DESIGNING A BOOK STYLE REPORT 

A Book Style Report enables you to print a series of mini-reports 
horizontally and vertically on a page.   
 
1. Open Report Writer. 
 
2. Click File > New or click on the New button on 

your toolbar.   
 

3. A list of all the property classes available will appear 
in the Select Class box.  Click the desired class of 
property for which you wish to design the book 
report. 

 
4. Select the Report Type of Book. From the Book 

Type listbox, select the desired number of reports to fit on the page. 
 
 
 
 
 
 
 

5. Click OK to continue.  A blank report will open for you to create your 
book report. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 



               Chapter 12 – Designing a Book Style Report 

   Page 68 

Inserting Fields 

Drag and drop the desired data fields onto the working area of the book 
report and/or insert text fields. 
 
In the example below, we inserted the Picture Grid (see Inserting Picture 
Grids on page 23), inserted Data Fields (see Inserting and Formatting Data 
Fields on page 14), inserted text fields (see Inserting and Formatting Text 
Fields on page 12) and merged the City and Zip code fields (see Inserting 
and Formatting Merging Fields on page 36). 
 
 
 
 
 
 
 
 
 
 
 

 

 

 
 
 
 
 

Saving, Viewing, Opening, Revising, Printing and Deleting a 
Book Style Report 
 
To save, view, open, revise, print and delete a Book Style Report, you 
would follow the same steps you would take in a normal report (see 
Chapter 8 – Saving, Viewing, Opening, Revising, Printing and Deleting 
Reports on page 47). 
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CHAPTER 13 - REVISING STANDARD REPORTS 
 

Revising Standard Reports 

In addition to creating and revising your own custom reports you may 
revise and save any of the standard report designs.  All revisions must be 
made from within Report Writer.  To revise a standard report, follow these 
steps: 
 
1. While in Report Writer, click on File > Open 

Custom Report. 
 

2. The Open Custom Report dialog box automatically 
opens at the Cust_rpt directory.  You need to find the 
std_rpt directory. 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Click on the drop down arrow in the Look in box and click on 
WyldFyre 6 folder, then double click on the std_rpt directory to view 
the file names which identify the various standard formats.  The 
numbers following the file names refer to the class of property the 
report was created in. 
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4. Double click on the file name or highlight the file name and click the 
Open button to view the report design in Report Writer. In our 
example, we are opening the ful01.rpt report. 

 
 
 

 
 
 
 
 
 
 
 

5. Before you edit your report, you MUST save your "new" design by 
clicking File > Save As.  We saved our report as “My full rpt”. 

 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

6. You may now edit the original design as you would a new report.   
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7. Be sure to save your changes again by clicking on File > Save. 
 

8. The revised report is now accessible through Listings as a custom 
report saved in the cust_rpt directory. 
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